4장을 읽다보니 건성으로 넘어간 2장의 object개념이 가물가물하다…쩝..어쩔수없이 되돌아와서 2장을 정리하고 넘어가야 할것 같다.
http://java.sun.com/docs/books/tutorial/java/concepts/index.html

- Object는 object-oriented technology를 이해하기 위한 핵심이고 실생활(real-world)에서 많은 object의 예를 볼 수있다. (your dog, your desk, your televison set, your bicycle 등등)
이러한 실생활의 objects는 두가지 특성을 가진다: state, behavior
예). your dog
state: name, color, breed(새끼를낳다),hungry
behavior: barking, fetching, wagging tail

- 실생활의 object들이 state와 behavior를 가지듯 softeware object도 state와 behavior를 가진다. software object는 자신의 state를 하나 이상의 변수(variable)에 유지한다. variable는 식별자(identifier)로명명ㄷ한 데이터의 항목이다. behavior는 method에 의해 구현되는데 method는 object에 연관된 function(subroutine)이다.

* An object is a software bundle of variables and related methods.

- 실생황의 objects나 GUI에서 event와 같은 추상적인 개념을 표현하기 위해서 Software Object를 사용할 수 있다.
- software object가 아는것(state)와 할 수 있는것(behavior)모두는 variable와 methods에 의해 표현된다.
- object-oriented에서 개개의 object를 instance라고하고 그것의 state를 저장하는 변수를 instance variable이라한다.

Posted by salgunamu
:

http://java.sun.com/docs/books/tutorial/java/data/index.html
이장은 object의 life cycle을 설명한다. 어떻게 object를 생성하고, 어떻게 사용하고 더 이상 사용할 필요가 없는경우에 시스템이 어떻게 clean을 하는지를 정의한다.

Core Classes
- Character data : java.lang에 있는 4개의 classes(Character, String, StringBuilder,StringBuffer)중의 하나에 의해서 단일 문자나 연속적인 문자들을 저장하고 조작할 수 있다.
- Numeric data : number class와 그것의 subclasses들로 표현된다. number class는 자바 플랫폼에서 모든 number class들의 superclass이다. java.lang패키지안에는 Byte,Double,Float,Integer, Long, Shot가 있고 java.math패키지에는 BigDecimal, BigInteger가 있다.
- Arrays : 동일한 형의 다중값들을 하나의 object로 그룹하기 위한 것으로 자바언어에서 array class는 없고, 직접적으로 지원된다. Array는 Object class의 함축적인 확장이다. 그래서 Object로 선언된 같은 type의 변수에 array를 선언할 수 있다.

자바 플랫폼은 classes들을 기능적인 packages로 그룹핑해서 제공하기 때문에 자신의 class를 작성하는 대신에 자바플랫폼에서 제공하는 class를 사용하는 것이 좋다. 4장에서 사용되는 대부분의 classes들은 java.lang에 포함되어져 있고, 당신의 프로그램상에서 import문을 사용하지 않더라도 자동적으로 포함된다.

==The Life Cycle of an Object==
일반적인 자바 프로그램은 많은 object들을 생성하고 생성된 object들간에 message를 보냄으로써 상호동작하여 여러가지 작업들을 수행하게 된다.

Posted by salgunamu
:

Cisco라우터에서 PPTP VPN을 받아주는 시험을 해봤다. 원격에서 VPN연결하면 사설을 사용하는 사무실의 네트웍과 많은 일을 할 수 있을것이다. Cisco2621 Ver 12.2(31)과 Windows Xp를 이용하여 시험했다. 아래는 구성도와 라우터의 샘플이다.

사용자 삽입 이미지
2621#show run
Building configuration…
Current configuration : 1566 bytes
!
version 12.2
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
!
hostname 2621
!
boot system flash
logging queue-limit 100
enable secret 5 $1$dGFC$VA28yOWzxlCKyj1dq8SkE/
!
username cisco password 0 cisco123
username client password 0 testclient

ip subnet-zero
ip cef
!
no ip domain lookup
ip domain name cisco.com
!
vpdn enable
!— Enable VDPN.
vpdn-group 1
!— Default PPTP VPDN group.
accept-dialin
protocol pptp
virtual-template 1
!
voice call carrier capacity active
!
no voice hpi capture buffer
no voice hpi capture destination
!
mta receive maximum-recipients 0
!
controller T1 0/0
framing sf
linecode ami
!
controller T1 0/1
framing sf
linecode ami
!
interface Loopback0
ip address 10.100.100.1 255.255.255.0
ip nat inside
!
interface FastEthernet0/0
ip address 172.16.142.191 255.255.255.0
no ip route-cache
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.130.13.13 255.255.0.0
duplex auto
speed auto
!
!— Create virtual-template interface used for “cloning”
!— virtual-access interfaces using address pool “test”
!— with CHAP authentication, PAP, and MS-CHAP.
interface Virtual-Template1
ip unnumbered FastEthernet0/0
peer default ip address pool test
no keepalive
ppp encrypt mppe auto
ppp authentication pap chap ms-chap

!
!— Create IP Pool named “test” and specify IP range.
ip local pool test 192.168.1.1 192.168.1.250
no ip http server
no ip http secure-server
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.142.1
!
ip pim bidir-enable
!
call rsvp-sync
!
mgcp profile default
!
dial-peer cor custom
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
password cisco
login
!
!
end
2621#

Posted by salgunamu
: